README.md
The CentOS Plus Repository

This repository is for items that actually upgrade certain base CentOS
componets. This repo will change CentOS to not be exactly like the
upstream providers content.

The CentOS developement team has tested every item in this repo, and
they build and work under CentOS-4. They have not been tested by the
upstream provider, and are not available in the upstream products.

You should understand that use of these components removes the 100%
binary compatibility with the upstream products. That said, here is
what is available in this repo.

In the below descriptions, the exact versioning has been replaced with
x's ... as this is generic information. See the actual RPM directories
in the ARCH that you are interested in for the latest version of each
of the packages for that specific ARCH.

Every effort will be made to keep these files updated, BUT the main
CentOS distro will be updated first, and these files will be updated
after the main distro updates have been completed and pushed. This
should not cause a considerable delay, and normally updates should
be completed on the same day as in the main distro. You might want
to exclude any packages from the [base] and [updates] section of your
/etc/yum.repos.d/CentOS-Base.repo file like this:

exclude=php* kernel* postfix*

If you do that to the [updates] and [base] section for packages you
install from the CentOS Plus repo, you won't accidentally get updates
from the main tree.

-------------------------
php-5.x.x-x.centos4
-------------------------
This is php-5 for CentOS-4. It replaces the php-4.3.9 that is currently
in CentOS-4. In order to upgrade a current php-4 install, you must
remove php-domxml first and then do:

yum --enablerepo=centosplus upgrade php*

or to do and install, use this command:

yum --enablerepo=centosplus --exclude=php-domxml install php*

(or install individually the files that you need)

-------------------------------------
postfix-2.x.x-x.x.RHEL4.mysql.centos4
-------------------------------------
This is Postfix compiled with mysql support so that you can use a MySQL
database for both usernames and to hold mail. If you need mysql support
for your postfix mail server, you can upgrade a currently installed
version like this:

yum --enablerepo=centosplus upgrade postfix*

or do an install like this:

yum --enablerepo=centosplus install postfix*

----------------------------------
kernel-2.6.x-x.x.x.xxx.unsupported
----------------------------------
This is a kernel that has many of the options and modules turned on which
are turned off by default in the upstream providers kernels. A list of
some of the items that this Kernel includes are:

File Systems:
NTFS (read and write)
XFS (read and write)
JFS (read and write)
ReiserFS (read and write)
UFS {BSD default FS} (read only)
BeOS FS (read only)
AFS (read only)

Hardware Modules:
All USB
All Firewire
All SCSI
Video4 Linux and all Video, Audio and Radio modules

IPX, DECNET, netware file mount support, ability to write to a Windows
Dynamic Partition. There are other items as well. See this link for
the actual config files used to build the latest unsupported kernel:

http://mirror.centos.org/centos/4/docs/kernel-unsupported/

---------------------
File System Utilities
---------------------
Because of the added file system support for the above kernel, we have
also added tools to create XFS, JFS and ReiserFS partitions and make
file systems on those partitions. Here are the packages for each FS:

XFS:
dmapi
dmapi-devel
xfsdump
xfsprogs
xfsprogs-devel

JFS:
jfsutils

ReiserFS:
reiserfs-utils


Thanks,
The CentOS Development Team